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Can I still use a Processor?

YES!
Three Altera Soft Processor Choices:
− Nios II/f Fast: Optimized for Performance
− Nios II/s Standard: Faster and Smaller than Nios
− Nios II/e Economy: Smallest FPGA Footprint 

Choose peripherals you want
SOPC Builder software builds interfaces, arbitration etc.

Nios II/e Nios II/s Nios II/fSmaller Faster
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Altera Quartus II CAD Tools
// Begin: Write Control

always @ (posedge wrbusy_int)
begin

write0 <= 1'b1;
write1 <= 1'b0;
writex <= 1'b0;

end

always @ (negedge wrbusy_int)
begin

write0 <= 1'b0;
end

always @ (posedge write0_done)
begin

write1 <= 1'b1;

// Begin: Write Control
always @ (posedge wrbusy_int)
begin

write0 <= 1'b1;
write1 <= 1'b0;
writex <= 1'b0;

end

always @ (negedge wrbusy_int)
begin

write0 <= 1'b0;
end

always @ (posedge write0_done)
begin

write1 <= 1'b1;

// Begin: Write Control
always @ (posedge wrbusy_int)
begin

write0 <= 1'b1;
write1 <= 1'b0;
writex <= 1'b0;

end

always @ (negedge wrbusy_int)
begin

write0 <= 1'b0;
end

always @ (posedge write0_done)
begin

write1 <= 1'b1;

Schematic, 
Verilog HDL,
VHDL

Host
Computer

USB CableCAD tools
QUARTUS II
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DE0 – Switches 
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DE0 – LEDs 
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DE0 – 7-segment displays
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Developing Digital Logic courses with 
Altera Technology

Tutorial #1
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Outline

Creating projects in Quartus II
Targeting a project for a DE0 Board
Downloading a circuit onto a DE0 board
Compiling and debugging
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Step 1: Start Quartus II

Message Window

Project Navigator

Status Window
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Step 2: Create a New Project

Click File Menu
Select New Project 
Wizard
This will open a new 
window where project 
information can be 
specified
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Project Name and Directory

The project must have a 
name, which is usually the 
same as the top-level design 
entity that will be included in 
the project.
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Add Source Files to Project

The wizard makes it easy 
to specify which existing 
files (if any) should be 
included in the project. 
Assuming that we do not 
have any existing files, click 
Next
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Specify FPGA Device

Select the FPGA device 
on the board
− Cyclone III Family

For DE0 – EP3C16F484C6

− Cyclone II Family
For DE1 – EP2C20F484C7
For DE2 – EP2C35F672C6
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Additional EDA Tools 

Specify Tools, in 
addition to 
Quartus II, that 
you will use
These are 
unnecessary for 
small student 
designs
− Leave all entries as 

<None>
− Press Next
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New Project Summary

• A summary of the 
chosen settings 
appears in the 
screen shown in 
Figure.

• Press Finish, 
which returns to 
the main Quartus 
II window, but 
with light specified 
as the new 
project, in the 
display title bar
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Simple Project
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Step 3a: Create Source File

• Select File > New to get 
the window in Figure, 
choose VHDL File, and 
click OK. This opens the 
Text Editor window. 

• Specify a name for the 
file that will be created 
and select File > Save to 
open a pop-up box and 
in the box labeled Save 
as type choose VHDL 
File
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Step 3b: Add Source File

Select:
•Assignments > 
Settings and 
looks for File 
item or
•Project > 
Add/Remove 
Files in Project
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Step 4: Assign Pins to connect switches/lights 
to inputs and outputs of your circuit

Click Assignments, then 
Import Assignments…
Import file
− DE0_pin_assignments.qsf

Imports locations for 
predefined port names, 
such as SW, LEDG, KEY, 
and others
− Can be done manually for 

custom port names
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Step 4: Assign Pins to connect switches/lights 
to inputs and outputs of your circuit

# Pin & Location Assignments
# ==========================
set_location_assignment PIN_B1 -to LEDG[9]
set_location_assignment PIN_B2 -to LEDG[8]
set_location_assignment PIN_C2 -to LEDG[7]
set_location_assignment PIN_C1 -to LEDG[6]
set_location_assignment PIN_E1 -to LEDG[5]
set_location_assignment PIN_F2 -to LEDG[4]
set_location_assignment PIN_H1 -to LEDG[3]
set_location_assignment PIN_J3 -to LEDG[2]
set_location_assignment PIN_J2 -to LEDG[1]
set_location_assignment PIN_J1 -to LEDG[0]
set_location_assignment PIN_D2 -to SW[9]
set_location_assignment PIN_E4 -to SW[8]
set_location_assignment PIN_E3 -to SW[7]
set_location_assignment PIN_H7 -to SW[6]
set_location_assignment PIN_J7 -to SW[5]
set_location_assignment PIN_G5 -to SW[4]
set_location_assignment PIN_G4 -to SW[3]
set_location_assignment PIN_H6 -to SW[2]
set_location_assignment PIN_H5 -to SW[1]
set_location_assignment PIN_J6 -to SW[0]
set_location_assignment PIN_F1 -to KEY[2]
set_location_assignment PIN_G3 -to KEY[1]
set_location_assignment PIN_H2 -to KEY[0]

# Pin & Location Assignments
# ==========================
set_location_assignment PIN_E11 -to HEX0[0]
set_location_assignment PIN_F11 -to HEX0[1]
set_location_assignment PIN_H12 -to HEX0[2]
set_location_assignment PIN_H13 -to HEX0[3]
set_location_assignment PIN_G12 -to HEX0[4]
set_location_assignment PIN_F12 -to HEX0[5]
set_location_assignment PIN_F13 -to HEX0[6]
set_location_assignment PIN_D13 -to HEX0[7]
set_location_assignment PIN_A15 -to HEX1[6]
set_location_assignment PIN_E14 -to HEX1[5]
set_location_assignment PIN_B14 -to HEX1[4]
set_location_assignment PIN_A14 -to HEX1[3]
set_location_assignment PIN_C13 -to HEX1[2]
set_location_assignment PIN_B13 -to HEX1[1]
set_location_assignment PIN_A13 -to HEX1[0]
set_location_assignment PIN_B15 -to HEX1[7]

# Pin & Location Assignments
# ==========================
set_location_assignment PIN_F14 -to HEX2[6]
set_location_assignment PIN_B17 -to HEX2[5]
set_location_assignment PIN_A17 -to HEX2[4]
set_location_assignment PIN_E15 -to HEX2[3]
set_location_assignment PIN_B16 -to HEX2[2]
set_location_assignment PIN_A16 -to HEX2[1]
set_location_assignment PIN_D15 -to HEX2[0]
set_location_assignment PIN_A18 -to HEX2[7]
set_location_assignment PIN_G15 -to HEX3[6]
set_location_assignment PIN_D19 -to HEX3[5]
set_location_assignment PIN_C19 -to HEX3[4]
set_location_assignment PIN_B19 -to HEX3[3]
set_location_assignment PIN_A19 -to HEX3[2]
set_location_assignment PIN_F15 -to HEX3[1]
set_location_assignment PIN_B18 -to HEX3[0]
set_location_assignment PIN_G16 -to HEX3[7]

SW: IN STD_LOGIC_VECTOR(N DOWNTO 0);
LEDG: OUT STD_LOGIC_VECTOR(N DOWNTO 0);
HEX0: OUT STD_LOGIC_VECTOR(0 TO N)

x1, x2, f ?????
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Step 5: Compile Design

Synthesis
Placement
& Routing

Timing & 
Power

Analysis

// Begin: Write Control
always @ (posedge wrbusy_int)
begin

write0 <= 1'b1;
write1 <= 1'b0;
writex <= 1'b0;

end

always @ (negedge wrbusy_int)
begin

write0 <= 1'b0;
end

always @ (posedge write0_done)
begin

write1 <= 1'b1;

// Begin: Write Control
always @ (posedge wrbusy_int)
begin

write0 <= 1'b1;
write1 <= 1'b0;
writex <= 1'b0;

end

always @ (negedge wrbusy_int)
begin

write0 <= 1'b0;
end

always @ (posedge write0_done)
begin

write1 <= 1'b1;

// Begin: Write Control
always @ (posedge wrbusy_int)
begin

write0 <= 1'b1;
write1 <= 1'b0;
writex <= 1'b0;

end

always @ (negedge wrbusy_int)
begin

write0 <= 1'b0;
end

always @ (posedge write0_done)
begin

write1 <= 1'b1;

Verilog,
VHDL

ReportAssembler

• Run the Compiler by selecting Processing > Start 
Compilation, or by clicking on the toolbar icon that 
looks like a purple triangle.

• Successful (or unsuccessful) compilation is indicated in 
a pop-up box; acknowledge it by clicking OK, which 
leads to the report shown in next slide
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Step 6: Examine Compilation Report
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Step 7a: Program the DE0 Board
• FPGA JTAG mode: it will retain its configuration as long as the power 

remains turned on. 
• Active Serial (AS) mode: a configuration device that includes some flash 

memory is used to store the configuration data

• FPGA JTAG mode: flip the RUN/PROG switch into the RUN position and 
select Tools > Programmer

• Observe that the 
configuration file 
light.sof is listed in 
the programmer 
window. If the file 
is not already 
listed, then click 
Add File and 
select it
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Step 7a: Program the DE0 Board
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Step 7b: Program the DE0 Board
• Here it is also necessary to specify the programming hardware and the mode 

that should be used. If not already chosen by default, select JTAG in the 
Mode box. 

• Also, if the USB-Blaster is not chosen by default, press the Hardware Setup... 
button and select the USB-Blaster in the window that pops up
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Step 7c: Program the DE0 Board
• Click on the Program/Configure check box
• Press Start in the Programmer window; an LED on the board will light up 

when the configuration data has been downloaded successfully
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Step 8: See your design work on the board

Having downloaded the configuration data into 
the FPGA device, you can now test the 
implemented circuit. 
Flip the RUN/PROG switch to RUN position. 
Try all four valuations of the input variables x1 
and x2, by setting the corresponding states of the 
switches SW1 and SW0.
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Step 9a: Simulate your design
Select Start > All Programs > Altera > University Program > 
Simulation Tools > QSim to open the Qsim tools.
Select File > Open Project to display a popup window in which you 
can browse your directories and choose a project file (.qpf file). 
Select the project you wish to simulate and click OK.
Generate the node finder files by selecting Processing > Generate 
Node Finder Files
From QSim, open the Waveform Editor window by selecting File > 
New Simulation Input File.
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Step 9b: Simulate your design
Save the file under the name light.vwf; note that this changes the 
name in the displayed window. 
Set the desired simulation to run from 0 to 200 ns by selecting Edit > 
Set End Time and entering 200 ns in the dialog box that pops up.
Select View > Fit in Window
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Step 9c: Simulate your design
Include the input and output nodes of the circuit to be simulated.
Click Edit > Insert > Insert Node or Bus: it is possible to type the 
name of a signal (pin) into the Name box, or use the Node Finder to 
search your project for the signals.
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Step 9d: Simulate your design
We will now specify the logic values to be used for the input signals 
x1 and x2 during simulation
Click on the waveform for the x1 node and using the Edit > Value
command, or via the toolbar, draw the desired waveforms.
Commands are available for setting a selected signal to 0, 1, 
unknown (X), high impedance (Z), weak low (L), weak high (H), a 
count value (C), an arbitrary value, a random value (R), inverting its 
existing value (INV), or defining a clock waveform.
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Step 9e: Simulate your design
E.g. set x2 to 1 in the time interval 50 to 100 ns . Do this by pressing 
the mouse at the start of the interval and dragging it to its end, which 
highlights the selected interval, and choosing the logic value 1 in the 
toolbar.
Observe that the output f is displayed as having an unknown value at 
this time, which is indicated by a hashed pattern; its value will be 
determined during simulation. 
Save the file.
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Step 9f: Simulate your design
To perform the functional simulation, return to the QSim Window and 
select Assign > Simulation Settings...
Click the Browse button and select the light.vwf file you created.
Choose Functional as the simulation type, and click OK. 
Select Processing > Generate Simulation Netlist.
A simulation run is started by Processing > Start Simulation,
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Step 9g: Simulate your design
To perform timing simulation choose Select Assign > Simulation 
Settings... 
Choose Timing as the simulation type, and click OK.
Run the simulator
Observe that there is a delay in producing a change in the signal f 
from the time when the input signals, x1 and x2, change their values. 
This delay is due to the propagation delays in the logic element and 
the wires in the FPGA device
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FSM Viewer

Open the FSM 
Viewer
− Click Tools
− Expand Netlist 

Viewers
− Click State 

Machine Viewer
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Examine State Machine
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See the Circuit in RTL Viewer

Start the RTL 
Viewer
− Click Tools
− Expand the 

Netlist Viewers
list

− Click RTL 
Viewer
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Examine the Circuit
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SignalTap II Embedded Logic Analyzer

A soft logic analyzer
− Instantiate as a module in your 

design

Connects to the board on 
which a design is running
Collects data when a 
trigger event occurs
Displays data on your 
computer

How does it work?
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FPGA

SignalTap II Operation

SignalTap Module

Green LEDs

User Logic
enable

ClockClock

User
FSM

KEY[0]
KEY[1]

USB-Blaster
cable
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Altera U. P. Teaching Materials for Digital Logic

Available for download: http://university.altera.com

Tutorials
− Teach students how to use Quartus II, etc.

Lab Exercises
− 10 digital logic exercises
− Complete with documentation and solutions (both in Verilog and VHDL)

IP Cores for DE boards
− VGA, Audio I/O, and others
− Great for projects
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Altera U.P. Web Site



© 2010 Altera Corporation

ALTERA, ARRIA, CYCLONE, HARDCOPY, MAX, MEGACORE, NIOS, QUARTUS & STRATIX are Reg. U.S. Pat. & Tm. Off. 
and Altera marks in and outside the U.S.
46

Tutorials

Tutorials
− Getting Started with Altera’s DE0 Lab Board
− Introduction to Quartus II

With Verilog, or VHDL, or Schematic
− Using library modules (LPMs)

With Verilog or VHDL
− Quartus II Simulation

With Verilog or VHDL
− Timing Considerations

With Verilog or VHDL
− Signal Tap II
− Hardware Debugging
− Debugging with ModelSim

Introduction to Quartus II

Acrobat Document
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Digital Logic Lab Exercises

Ten lab exercises released
− From basic logic gates to simple processors:

Lab 1: Switches, Lights, and Multiplexers
Lab 2: Numbers and Displays
Lab 3: Latches, Flip-flops, and Registers
Lab 4: Counters
Lab 5: Real-time Clock and Timers
Lab 6: Adders, Subtractors, and Multipliers
Lab 7: Finite State Machines
Lab 8: Memory Blocks
Lab 9: A Simple Processor
Lab 10: An Enhanced Processor
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Lab 1: Switches and Lights

/* connect switches to lights through FPGA */
LEDG(9) <= SW(9);
LEDG(8) <= SW(8);
. . .
LEDG <= SW;

/* build a 2-to-1 multiplexer */

Part 1

Part 2
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… Lab 1 m <= (NOT(s) AND x) OR (s AND y);
…
Make 3 copies for 3-bit wide 2-to-1 multiplexers, 

then  connect to 3 LEDs

Part 2

Part 3 Build a more complex multiplexer:
2-bit wide 3-to-1 multiplexer
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… Lab 1

Part 4
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… Lab 1

Part 5

Part 5

Select and display one of three characters

Rotate the word dE0 on three displays
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… Lab 1

Part 6

Extend your design from Part V so that is uses all 
four 7-segment displays on the DE0 board
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Lab 7

FSM – Sequence 
recognizer
− There is an input w and an 

output z. 
− Whenever w = 1 or w = 0 for 

four consecutive clock pulses 
the value of z has to be 1; 
otherwise, z = 0. 

− Overlapping sequences are 
allowed, so that if w = 1 for 
five consecutive clock pulses 
the output z will be equal to 1 
after the fourth and fifth pulses

Part 1
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Lab 7 Part 1

Current State W Next state Z
A: 000000001 0 B: 000000010 0

B: 000000010 0 C: 000000100 0

C: 000000100 0 D: 000001000 0

D: 000001000 0 E: 000010000 0

E: 000010000 0 E: 000010000 1

F: 000100000 0 B: 000000010 0

G: 001000000 0 B: 000000010 0

H: 010000000 0 B: 000000010 0

I: 100000000 0 B: 000000010 1

Current State W Next state Z
A: 000000001 1 F: 000100000 0

B: 000000010 1 F: 000100000 0

C: 000000100 1 F: 000100000 0

D: 000001000 1 F: 000100000 0

E: 000010000 1 F: 000100000 1

F: 000100000 1 G: 001000000 0

G: 001000000 1 H: 010000000 0

H: 010000000 1 I: 100000000 0

I: 100000000 1 I: 100000000 1

Y_D(1) <= (y_Q(0) OR 
y_Q(5) OR y_Q(6) OR 
y_Q(7) OR y_Q(8)) AND 
NOT (w);
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Lab 7

FSM – Sequence 
recognizer
− Describe the state table for the 

FSM by using a VHDL CASE 
statement in a PROCESS  
block, and use another 
PROCESS block to instantiate 
the state flip-flops.

Part 2

ARCHITECTURE Behavior OF part2 IS
SIGNAL Clock, Resetn, w, z : STD_LOGIC;
TYPE State_type IS (A, B, C, D, E, F, G, H, I);
SIGNAL y_Q, Y_D : State_type;

…




